CVE-2020-17533GHSA-GRC3-8Q8M-4J7C
Apache Accumulo Improper Handling of Insufficient Permissions
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.10.1, 2.0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
Apache Accumulo versions 1.5.0 through 1.10.0 and version 2.0.0 do not properly check the return value of some policy enforcement functions before permitting an authenticated user to perform certain administrative operations. Specifically, the return values of the 'canFlush' and 'canPerformSystemActions' security functions are not checked in some instances, therefore allowing an authenticated user with insufficient permissions to perform the following actions: flushing a table, shutting down Accumulo or an individual tablet server, and setting or removing system-wide Accumulo configuration properties.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Accumulo
From 1.5.0
- org.apache.accumulo:accumulo-masterMaven
From 1.5.0 · fixed in 1.10.1
- org.apache.accumulo:accumulo-masterMaven
From 2.0.0 · fixed in 2.0.1