A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.17, 2.8.11, 2.9.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat ansible
ansible-engine versions 2.7.x before 2.7.17, ansible-engine versions 2.8.x before 2.8.11, ansible-engine versions 2.9.x before 2.9.7, Ansible Tower <= 3.4.5, Ansible Tower <= 3.5.5, Ansible Tower <= 3.6.3
- ansiblePyPI
From 2.7.0 · fixed in 2.7.17; From 2.8.0 · fixed in 2.8.11; From 2.9.0 · fixed in 2.9.7
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.11
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.7
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.17