Skip to main content
← All vulnerabilities
CVE-2020-1739PYSEC-2020-11GHSA-923P-FR2C-G5M2

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of sv

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.17, 2.8.9, 2.9.6, 2.8.11, 2.9.7
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat Ansible

    Version range not reported

  • ansiblePyPI

    fixed in 2.7.17; From 2.8.0 · fixed in 2.8.9; From 2.9.0 · fixed in 2.9.6

  • ansiblePyPI

    fixed in 2.7.17

  • ansiblePyPI

    From 2.8.0a1 · fixed in 2.8.11

  • ansiblePyPI

    From 2.9.0a1 · fixed in 2.9.7

References 7

bugzilla.redhat.com

GitHub · ansible/ansible

lists.fedoraproject.org

lists.debian.org

debian.org