Skip to main content
← All vulnerabilities
CVE-2020-1738GHSA-F85H-23MF-2FWHPYSEC-2020-10

A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.17, 2.8.9, 2.9.6
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat ansible

    Version range not reported

  • ansiblePyPI

    through 2.7.16

  • ansiblePyPI

    From 2.8.0a1 · through 2.8.10

  • ansiblePyPI

    From 2.9.0a1 · through 2.9.6

  • ansiblePyPI

    fixed in 2.7.17; From 2.8.0 · fixed in 2.8.9; From 2.9.0 · fixed in 2.9.6

References 3

bugzilla.redhat.com

GitHub · ansible/ansible

security.gentoo.org