CVE-2020-1736GHSA-X7JH-595Q-WQ82PYSEC-2020-8
A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.17, 2.8.9, 2.9.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destination files world-readable if the destination file does not exist and if the file exists, the file could be changed to have less restrictive permissions before the move. This could lead to the disclosure of sensitive data. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat ansible
Version range not reported
- ansiblePyPI
From 2.7.0 · through 2.10.0
- ansiblePyPI
fixed in 2.7.17; From 2.8.0 · fixed in 2.8.9; From 2.9.0 · fixed in 2.9.6