CVE-2020-16251GHSA-4MP7-2M29-GQXFBIT-VAULT-2020-16251GO-2024-2488
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentica
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.2.5, 1.3.8, 1.4.4, 1.5.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/hashicorp/vaultGo
From 0.8.3 · fixed in 1.2.5
- github.com/hashicorp/vaultGo
From 1.3.0 · fixed in 1.3.8
- github.com/hashicorp/vaultGo
From 1.4.0 · fixed in 1.4.4
- github.com/hashicorp/vaultGo
From 1.5.0 · fixed in 1.5.1
- github.com/hashicorp/vaultGo
From 0.8.3 · fixed in 1.2.5; From 1.3.0 · fixed in 1.3.8; From 1.4.0 · fixed in 1.4.4; From 1.5.0 · fixed in 1.5.1