Skip to main content
← All vulnerabilities
CVE-2020-16250GO-2022-0825BIT-VAULT-2020-16250GHSA-FP52-QW33-MFMW

HashiCorp Vault and Vault Enterprise versions 0.7.1 and newer, when configured with the AWS IAM auth method, may be vulnerable to authentica

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.2.5, 1.3.8, 1.4.4, 1.5.1
None on Exploit-DB, Metasploit or GitHub

Summary

HashiCorp Vault and Vault Enterprise versions 0.7.1 and newer, when configured with the AWS IAM auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1..

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/hashicorp/vaultGo

    From 0.8.1 · fixed in 1.2.5; From 1.3.0 · fixed in 1.3.8; From 1.4.0 · fixed in 1.4.4; From 1.5.0 · fixed in 1.5.1

  • github.com/hashicorp/vaultGo

    From 0.8.1 · fixed in 1.2.5

  • github.com/hashicorp/vaultGo

    From 1.3.0 · fixed in 1.3.8

  • github.com/hashicorp/vaultGo

    From 1.4.0 · fixed in 1.4.4

  • github.com/hashicorp/vaultGo

    From 1.5.0 · fixed in 1.5.1

References 3

hashicorp.com

GitHub · hashicorp/vault

packetstormsecurity.com