Skip to main content
← All vulnerabilities
CVE-2020-16104

SQL Injection vulnerability in Enterprise Data Interface of Gallagher Command Centre allows a remote attacker with 'Edit Enterprise Data Int

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6)
None on Exploit-DB, Metasploit or GitHub

Summary

SQL Injection vulnerability in Enterprise Data Interface of Gallagher Command Centre allows a remote attacker with 'Edit Enterprise Data Interfaces' privilege to execute arbitrary SQL against a third party database if EDI is configured to import data from this database. This issue affects: Gallagher Command Centre 8.30 versions prior to 8.30.1236(MR1); 8.20 versions prior to 8.20.1166(MR3); 8.10 versions prior to 8.10.1211(MR5); 8.00 versions prior to 8.00.1228(MR6); version 7.90 and prior versions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Gallagher Command Centre

    through 7.90; From 8.30 · fixed in 8.30.1236(MR1); From 8.20 · fixed in 8.20.1166(MR3); From 8.10 · fixed in 8.10.1211(MR5); From 8.00 · fixed in 8.00.1228(MR6)

References 1

security.gallagher.com