CVE-2020-15227GHSA-8GV3-3J7F-WG94
Remote Code Execution vulnerability
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 3 proofs of concept on GitHub, 1 Nuclei template
Summary
Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- nette application
From 2.0.0 · fixed in 2.0.19; From 2.1.0 · fixed in 2.1.13; From 2.2.0 · fixed in 2.2.10; From 2.3.0 · fixed in 2.3.14; From 2.4.0 · fixed in 2.4.16; From 3.0.0 · fixed in 3.0.6
- nette/applicationPackagist
From 2.2.0 · fixed in 2.2.10
- nette/applicationPackagist
From 2.3.0 · fixed in 2.3.14
- nette/applicationPackagist
From 2.4.0 · fixed in 2.4.16
- nette/applicationPackagist
From 3.0.0 · fixed in 3.0.6
- nette/applicationPackagist
From 2.0.0 · fixed in 2.0.19
- nette/applicationPackagist
From 2.1.0 · fixed in 2.1.13