Skip to main content
← All vulnerabilities
CVE-2020-15146GHSA-H6M7-J4H3-9RF5

Remote Code Execution in SyliusResourceBundle

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.3.14, 1.4.7, 1.5.2, 1.6.4
None on Exploit-DB, Metasploit or GitHub

Summary

In SyliusResourceBundle before versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4, request parameters injected inside an expression evaluated by `symfony/expression-language` package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution. This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Sylius SyliusResourceBundle

    fixed in 1.3.14; From 1.4.0 · fixed in 1.4.7; From 1.5.0 · fixed in 1.5.2; From 1.6.0 · fixed in 1.6.4

  • sylius/resource-bundlePackagist

    From 1.4.0 · fixed in 1.4.7

  • sylius/resource-bundlePackagist

    From 1.5.0 · fixed in 1.5.2

  • sylius/resource-bundlePackagist

    From 1.6.0 · fixed in 1.6.4

  • sylius/resource-bundlePackagist

    From 1.0.0 · fixed in 1.3.14

References 1

GitHub · Sylius/SyliusResourceBundle