CVE-2020-15115GHSA-4993-M7G5-R9HH
No minimum password length in etcd
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.3.23, 3.4.10
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
Timeline
- CVE published
- Record last updated
Affected versions
- etcd-io etcd
fixed in 3.3.23; fixed in 3.4.10
- go.etcd.io/etcd/client/v3Go
From 3.4.0 · fixed in 3.4.10
- go.etcd.io/etcd/client/v3Go
fixed in 3.3.23