CVE-2020-14365PYSEC-2020-209GHSA-M429-FHMV-C6Q2
A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packag
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.8.16rc1, 2.9.14rc1, 2.8.15, 2.9.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when disable_gpg_check is set to False, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a ansible
Version range not reported
- ansiblePyPI
From 2.8.0 · fixed in 2.8.16rc1; From 2.9.0 · fixed in 2.9.14rc1
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.15
- ansiblePyPI
From 2.9.0a1 · fixed in 2.9.13