CVE-2020-13672GHSA-3M36-MJWJ-352CBIT-DRUPAL-2020-13672DRUPAL-CORE-2021-002
Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circu
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 9.1.7, 9.0.12, 8.9.14, 7.80
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.
Timeline
- CVE published
- Record last updated
Affected versions
- Drupal Core
From 9.1.x · fixed in 9.1.7; From 9.0.x · fixed in 9.0.12; From 8.9.x · fixed in 8.9.14; From 7.x · fixed in 7.80
- drupal/corePackagist
From 7.0.0 · fixed in 7.80
- drupal/corePackagist
From 8.0.0 · fixed in 8.9.14
- drupal/corePackagist
From 9.0.0 · fixed in 9.0.12
- drupal/corePackagist
From 9.1.0 · fixed in 9.1.7
- drupal/drupalPackagist
From 7.0.0 · fixed in 7.80
- drupal/drupalPackagist
From 8.0.0 · fixed in 8.9.14
- drupal/drupalPackagist
From 9.0.0 · fixed in 9.0.12
- drupal/drupalPackagist
From 9.1.0 · fixed in 9.1.7
- drupal/corePackagist
From 8.0.0 · fixed in 8.9.14; From 9.0.0 · fixed in 9.0.12; From 9.1.0 · fixed in 9.1.7