Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.8.10, 8.9.6, 9.0.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.
Timeline
- CVE published
- Record last updated
Affected versions
- Drupal Drupal Core
From 8.8.X · fixed in 8.8.10; From 8.9.X · fixed in 8.9.6; From 9.0.X · fixed in 9.0.6
- drupal/corePackagist
From 8.8.0 · fixed in 8.8.10
- drupal/corePackagist
From 8.9.0 · fixed in 8.9.6
- drupal/corePackagist
From 9.0.0 · fixed in 9.0.6
- drupal/drupalPackagist
From 8.8.0 · fixed in 8.8.10
- drupal/drupalPackagist
From 8.9.0 · fixed in 8.9.6
- drupal/drupalPackagist
From 9.0.0 · fixed in 9.0.6
- drupal/corePackagist
From 8.0.0 · fixed in 8.8.10; From 8.9.0 · fixed in 8.9.6; From 9.0.0 · fixed in 9.0.6