Skip to main content
← All vulnerabilities
CVE-2020-13666GHSA-8JJ2-X2GC-GGM7BIT-DRUPAL-2020-13666DRUPAL-CORE-2020-007

Cross-site scripting vulnerability in Drupal Core.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.73, 8.8.10, 8.9.6, 9.0.6
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Drupal Drupal Core

    From 7.x · fixed in 7.73; From 8.8.x · fixed in 8.8.10; From 8.9.x · fixed in 8.9.6; From 9.0.x · fixed in 9.0.6

  • drupal/corePackagist

    From 8.8.0 · fixed in 8.8.10

  • drupal/corePackagist

    From 8.9.0 · fixed in 8.9.6

  • drupal/corePackagist

    From 9.0.0 · fixed in 9.0.6

  • drupal/corePackagist

    From 7.0.0 · fixed in 7.73

  • drupal/drupalPackagist

    From 7.0.0 · fixed in 7.73

  • drupal/drupalPackagist

    From 8.8.0 · fixed in 8.8.10

  • drupal/drupalPackagist

    From 8.9.0 · fixed in 8.9.6

  • drupal/drupalPackagist

    From 9.0.0 · fixed in 9.0.6

  • drupal/corePackagist

    From 8.0.0 · fixed in 8.8.10; From 8.9.0 · fixed in 8.9.6; From 9.0.0 · fixed in 9.0.6

References 1

drupal.org