Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.8.8, 8.9.1, 9.0.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.
Timeline
- CVE published
- Record last updated
Affected versions
- Drupal Drupal Core
From 8.8.x · fixed in 8.8.8; From 8.9.x · fixed in 8.9.1; From 9.0.1 · fixed in 9.0.1
- drupal/corePackagist
From 8.8.0 · fixed in 8.8.8
- drupal/corePackagist
From 8.9.0 · fixed in 8.9.1
- drupal/corePackagist
From 9.0.0 · fixed in 9.0.1
- drupal/drupalPackagist
From 8.8.0 · fixed in 8.8.8
- drupal/drupalPackagist
From 8.9.0 · fixed in 8.9.1
- drupal/drupalPackagist
From 9.0.0 · fixed in 9.0.1
- drupal/corePackagist
From 8.0.0 · fixed in 8.8.8; From 8.9.0 · fixed in 8.9.1; From 9.0.0 · fixed in 9.0.1