An issue was found in Apache Airflow versions 1.10.10 and below.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- Fix
- Fixed in 1.10.11rc1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Apache Airflow, a widely used workflow orchestration platform, is affected by this vulnerability in its older releases. An authenticated user could exploit it to run arbitrary commands with the privileges of the Airflow worker or scheduler process, potentially giving them control over the host system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An issue was found in Apache Airflow versions 1.10.10 and below. A remote code/command injection vulnerability was discovered in one of the example DAGs shipped with Airflow which would allow any authenticated user to run arbitrary commands as the user running airflow worker/scheduler (depending on the executor in use). If you already have examples disabled by setting load_examples=False in the config then you are not vulnerable.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apache Software Foundation Apache Airflow
1.10.10 and below
- apache-airflowPyPI
fixed in 1.10.11rc1
- apache-airflowPyPI
fixed in 1.10.11rc1