Skip to main content
← All vulnerabilities
CVE-2020-11973GHSA-H79P-32MX-FJJ9

Apache Camel Netty enables Java deserialization by default.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.0
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Camel Netty enables Java deserialization by default. Apache Camel 2.22.x, 2.23.x, 2.24.x, 2.25.0, 3.0.0 up to 3.1.0 are affected. 2.x users should upgrade to 2.25.1, 3.x users should upgrade to 3.2.0.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Apache Camel

    Version range not reported

  • org.apache.camel:camel-nettyMaven

    From 3.0.0 · fixed in 3.2.0

References 6

openwall.com

oracle.com

camel.apache.org